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Abstract. This article presents the Cisco Packet Tracer software interface and its capabilities, the 
tasks of existing devices in the software interface and their analysis, the creation of a computer 
network project "Building №1 of the Namangan Engineering-Construction Institute" using this 
software, and the classification of costs for the project. Designing a network with the help of this 
program provides many conveniences to users, including time saving, low cost, and low labor 
consumption.   
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INTRODUCTION 

After computers were created by humanity, it was very soon discovered that independent 
devices could not fully realize their potential capabilities. In addition, people understood the need 
to create a new approach to the processes of information processing, transmission and storage, as 
well as to the environment in which humanity can combine all its information resources. This 
concept was the first step in creating systems in which almost every citizen of the planet exists 
today.  

Today, local and global computer networks perform many functions, but the main thing is 
to combine all the information collected by humanity and give it access at any time and from 
anywhere in the world. The Association, which was influenced by local and global computer 
networks and continues at the same time, made it possible to create a system that allows large 
Information Media to work with incredible speed and provide access to almost any data volume. 

 
MAIN PART 

Cisco Packet Tracker software interface and its capabilities 
Cisco Packet Tracer software is developed by Cisco and is recommended for use in studying 

telecommunications networks and network equipment. Based on the Packet Tracer software, it is 
possible to create a network topology from various Cisco routers and switches, workstations and 
network connections such as Ethernet, Serial, ISDN, Frame Relay. The functions of the simulator 
can be suitable both for training and for work, as well as for configuring the network at the 
planning stage. 

Cisco Packet Tracer software interface and working window view below: 
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Fig.1. 

At the top of the window is the name of the program (Cisco Packet Tracer), the header 
section containing the name of the file that stores the computer network model, as well as the 
window resizing, compacting or closing it. 

The standard control buttons are located and they are below: 
 

 
Fig.2 

 
At the top of the header is the main menu bar, which contains the subs menu sections: 
The File menu includes the save and open file commands describing the network topology; 
The Edit menu underlay contains commands that allow you to edit the image in the working 

area; 
Options menu underlay serves for working area Settings; 
The View menu subsystem consists of user interface parameter setting commands; 
The Tools menu subsystem consists of commands that allow you to create an additional 

model of devices; 
Extensions under the menu allows you to ensure that utilities are allowed; 
The Help menu subsystem consists of commands that allow you to refer to a reference, view 

training materials, or view the current version of the Cisco Packet Tracer program. 
Below the menu bar is the top uskinas bar. 
The first line of buttons located on the top equipment panel Cisco Packet Tracer program 

consists of tabs made up of the most commonly used commands of the main menu bar: 
New-creating a new model; 
Open-model file loading; 
Save-save model to file; 
Print model from printer; 
Activity Wizard-creating a model simplification instruction; 
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Copy-copy the specified part of the model to the clipboard; 
Paste-putting the information in the buffer in the model window; 
Undoing the last modification to the Undo-model; 
Undo-undo to restore the undo modification; 
Zoom in-image zoom; 
Zoom Reset-Reset the initial size of the image; 
Zoom Out-shrink image; 
Drawing Palette - coloring the drawn elements of the model; 
Custom Devices Dialog-calling dasdtur, which creates the user interface of the device 

model; 
The second row of the upper equipment panel housed the following devices: 
Logical Physical-change the working Field Mode; 
Root Back-shrink and expand cluster button; 
New Cluster-button to merge devices into one group (cluster) ; 
Move Objects-push an object in a cluster; 
Set Tided Background-wallpaper selection button 
 

Functions of existing devices in the Cisco Packet Tracer software interface and their 
analysis. 

Cisco Packet Tracer is a network emulator created by Cisco. This program allows you to 
build networks on different equipment in optional topologies, supporting different protocols. The 
Cisco Packet Tracer software solution allows you to simulate the work of various network devices: 
routers, switches, wireless hotspots, personal computers, network printers, IP phones, etc. 
Working with an interactive simulator allows you to set up a real network of tens and even 
hundreds of devices. The settings, in turn, depend on the types of devices: some can be configured 
using the commands of the Cisco IOS operating system, others through a graphical web interface, 
and others through the operating system command line or graphic menus. 

 
Routers 

 

 
Fig.3. 

 
Routers are used to search for the optimal route of data transmission based on special 

routing algorithms, such as selecting a route (route) with the lowest number of transit nodes. 
There are 3 classes of routers they are below. Upper class routers are called Trunk routers. The 
productivity of routers in this variety will be the highest. With them, the trunk networks of 
enterprises or the global network of any God can be formed. With the help of trunk routers, the 
processing of several 100 thousand packets per second is carried out, and a few millions per 
second. Middle class routers are understood as routers designed for regional sections. With them, 



 

The Peerian Journal 
Open Access | Peer Reviewed  

Volume 31, June, 2024                                                          ISSN (E): 2788-0303 
Website: www.peerianjournal.com   Email: editor@peerianjournal.com 

 

 

37 | P a g e  

 

 

the connection of regional sections with the Central, that is, the trunk network is carried out. These 
routers are relatively simplified variants of upper-class routers. Lower-class routers are routers 
designed for long-distance officers. With them, the connection of not very large offices with the 
enterprise network is carried out. Such routers are designed to operate over channels with little 
speed, including connecting ports over telephone networks. 

 
Fig.4. 

 
Switchs 

 

 
Fig.5. 

 
Switches are devices that run on the link layer of the OSI model and are designed to 

combine multiple nodes in one or more network segments. The Switch transmits packets based on 
the internal table switching table, so traffic only goes to the MAC address to which it is intended 
and is not duplicated in all ports. 

 
Fig.6. 

 
 

HUB 
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Fig.7. 

 
The advantage of a concentrator over a commutator lies only in the fact that its ports are 

capable of amplifying the signal, and the cost is low. But after the number of connecting devices in 
the local network exceeds 8, the concentrator causes a decrease in the speed of operation of the 
network. Another major drawback is that the concentrator (hub) duplicates the packet received in 
one port to all other ports. 

 
Wireless devices 

 

 
Fig.8. 

 
Wireless Wi-Fi technologies and their based networks. Includes wireless access points. 

Wireless access point. In local area network construction, there may be cases where a wireless 
access point device will be necessary. For example:  

The local network was organized through a switch, but there are devices that must be 
connected to the local network via the Wi-Fi standard;  

The local network is connected to the internet through such a mashrutizer that there is no 
possibility of wireless connection to this router;  

The local network is connected to the internet via a modem that does not have a wireless 
connection; 

The local network is connected to the internet through such a router that the router is able 
to connect the local network devices via the Wi-Fi standard, but it is necessary to enlarge the scope 
of the Wi-Fi area that the router is forming. In all of the points listed above, a wireless hotspot 
device is used. 

 
Communication lines 
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Fig.9. 

 
These network cable components can create a number of network loihas in the Cisco Packet 

Tracer program. The tariffs on our cables will be as low. 
 

 
Fig.10. 

 
Provides a console connection between routers and switches and computers. In order to 

work with a computer, certain requirements must be met for a console session. Both sides must 
have the same baud rate, each side must have 7 bits of data (8 bits), the parity must be the same, 
there must be 1 or 2 stop bits, and no 'data flow can be any for both parties. 

 

 
Fig.11 

 
This type of copper cable provides a standard Ethernet environment for connecting devices 

operating at different levels of the OSI model (for example, hub - router, switch - PC, router - hub). 
The cable can be connected to the following types of ports: 10 Mbit / s (Ethernet), 100 Mbit / s 
(Fast Ethernet) and 1000 Mbit / s (Gigabit Ethernet). 

 

 
Fig.12. 
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Connection According to the OSI model, a copper Ethernet medium is used to connect 
devices operating at the same level (for example, HUB - HUB, PC - PC, PC printer). The cable can 
be connected to the following types of ports: 10 Mbit / s (Ethernet), 100 Mbit / s (Fast Ethernet) 
and 1000 Mbit / s (Gigabit Ethernet). 

 
Fig.13. 

Fiber optic cable is used to connect optical ports (100 Mbit/s or 1000 Mbit/s). 

 
Fig.14. 

A telephone cable can be connected between devices with modem ports. An example of a 
modem connection is to connect a computer to the Internet through a telephone line using a 
modem. 

 
Fig.15. 

A coaxial cable is used between coaxial ports, such as cable modem ports. 
 

 
Fig.16. 

 
This type of connection is often used to establish WAN connections. Then the cable is 

connected to the WAN ports of the devices. If this connection type is selected, one device performs 
the function of DCE and the other automatically acts as the DTE side. The presence of a clock 
symbol on the corresponding end of the connection indicates that this end performs the function 
of DCE. 

 
Devices 

 
Fig.17. 
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Here are the latest devices, computers, servers, printers, phones and other devices.  
 

Internet emulation 
 

 
Fig.18. 

 
An example of global network emulation. DSL modem, cloud and more. Cloud for user 

devices and multi-user work. 

 
Fig.19. 

 
Devices can be assembled independently. You can create optional connections using these 

devices. 
 

Physical configuration of the equipment. 
Install the Cisco 1841 router in the workspace and when we start it, the settings and 

configuration of the router will open. 

 
Fig.20.  

 
1. The function of turning the router off and on is shown, if the green light is on, then we can 

know that the router is on, otherwise it is off. 
2. On the left, as we can see, the list of modules with which this router can be equipped. 
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3. There are 2 ports on the router where the module can be inserted. You can install them 
only after selecting the desired module in number 2 and making sure that the router is turned off. 

 
RESULTS  

Creating a computer network project in the Cisco Packet Tracer program. 
 

To perform this task, we will first run Cisco Packet Tracer. 
The working window will look like this: 

 
Fig.21. 

 
We draw a drawing of the building we want to design. Since we have 4 floors that are shakily 

identical, the other 4 floors will be the same. The rest of the floors are hajman small, but they are 
like that. 

 

 
Fig.22. 

 
In the following part, we can place the necessary devices in the rooms.  
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Fig.23. 

 
In the next steps, we connect them through cables (wrap pair) and also give colors for their 

design. 
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Fig.24. 

 
After this process, we proceed to the process of configuring the switch, computer and other 

structures. We start the work by first giving ip to the DNCP server. We give our DNCP server ipsini 
192.168.2.2, Getway 192.168.2.1 and mask 255.255.255.0. 

 
Fig.25. 

 
In the next step, we check whether IP addresses on computers are dynamically given. 
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Fig.26. 

 
In the next step, we will show that they are sharing information with one another. 

 
Fig.27. 
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